Jump to content

No Plumes of Smoke in Tesla Prayer QAB1

Recommended Posts

So I have made three civilizations so far. In my first one, this quest worked fine. In my second one, I never got any plumes of smoke and thus failed this prayer, my civilization died out (not as a result of this, though) so I started a new one. Now, in this current civilization I have the Tesla prayer started but still no plumes of smoke, 30 seconds left so I will be failing it this time, too. Has this happened to anyone else?

Share this post

Link to post
Share on other sites

You're positive the plumes did not appear after placing the battery? If this occurs again, wait about 30 seconds after placing the battery, then you can pause and the smoke should have appeared. Since you're paused however, you can take whatever time you need to find it.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now