Jump to content
okster

linux: game crashes when starting new game

Recommended Posts

SUMMARY

Game crashes after clicking 'start new life'

REPLICATION

  Start game (from command line or steam, with or without steam overlay)

  Theres some music but with a black screen (presumably splash screen not loading)

  Then menu appears - rotating planet and all (very pretty)

  Click on 'new game'

  Game exists while displaying cute loading messages

OS
mint 19 (based on ubuntu 18.04)
fully updated (2 day old fresh install as it happens)
GeForce GTX 980M with nvidia 390.48 drivers

OTHER NOTES
Missing libs messages in Player.log
The\ Universim/The\ Universim_Data/Mono/x86_64 only has these files:
  libMonoPosixHelper.so  libmono.so

Tried uninstall and re-install, and verification no change

 

*** There are two other reports like this one attached to

even though they are not for a mac and they are reporting a different problem. Perhaps @dissonance and @Haeffound 's posts should be moved here? or maybe they can just '+1' with a link to their other post :D

 

 

Player.log

Share this post


Link to post
Share on other sites

I'm having the same exact issue, same summary and replication. Also Linux. Other games and GPU usage is fine, no other issues.

 

OS: Arch Linux
Kernel: x86_64 Linux 4.18.5-arch1-1-ARCH
WM: dwm
CPU: Intel Core i7-4850HQ @ 8x 2.3GHz
GPU: GeForce GT 750M
GPU Driver: nvidia 396.54-2
RAM: 16GB

 

Share this post


Link to post
Share on other sites

Sorry to double post, but I figured out a fix (at least for me)!

 

I was reading the logs in ~/.config/unity3d/Crytivo Games Inc_/The Universim/Player.log and found a traceback that showed that the /home/user/.local/share/Steam/steamapps/common/The Universim/The Universim_Data/Mono/x86_64/libsteam_api.so file was missing. On a whim, I did a search for *libsteam_api.so in another game folder (Sanctum 2), found it, copied it over to the missing spot, restarted the game, AND IT WORKED.

 

I'm a software developer, so I'll explain what I think is happening. For whatever reason, the packaging for The Universim is not copying a shared library. It seems that the game crashes when it tries to load this. After applying the fix and starting the game, at the time that the crash would normally happen there is a flash (at least on my box) where it loads up a quick steam window. I'm guessing that the libsteam_api.so library is being accessed to setup some kind of callback to the steam application. Since the shared library isn't there, it basically faults and crashes. I'm not sure if there are any other libraries missing, but I've been playing the game for about an hour now and it's been running incredibly smooth on medium-ish settings, playable enough on top settings.

 

FIX:

0. Start Steam, launch the game, continue until it crashes.

1. Check log file at ~/.config/unity3d/Crytivo Games Inc_/The Universim/Player.log and verify that there is a error similar to "Fallback handler could not load library /home/user/.local/share/Steam/steamapps/common/The Universim/The Universim_Data/Mono/x86_64/libsteam_api.so"

2. Search in another game folder in "/home/user/.local/share/Steam/steamapps/common" for a file called libsteam_api.so:

[breakingmatter:~]$ find ~/.local/share/Steam/steamapps/common/ -name "*libsteam_api.so"
/home/user/.local/share/Steam/steamapps/common/Sanctum2/Binaries/linux-amd64/libsteam_api.so
/home/user/.local/share/Steam/steamapps/common/Sanctum2/Binaries/linux-x86/libsteam_api.so

3. Copy the file to the missing location (make sure that you select the correct architecture/platform, as it is a shared library and will be platform dependent):

[breakingmatter:~]$ cp /home/user/.local/share/Steam/steamapps/common/Sanctum2/Binaries/linux-amd64/libsteam_api.so "/home/user/.local/share/Steam/steamapps/common/The Universim/The Universim_Data/Mono/x86_64/libsteam_api.so"

4. Start the game. Attempt to play.

5. Hopefully, you come back to this browser window a few hours later after you've enjoyed the game like I have! :)

Share this post


Link to post
Share on other sites

I saw this fix on the Steam forum indeed, for the nvidia cards, but I haven't anothe X64 unity game where to get this library...

 

And indeed, it is the same error on my side. Maybe someone or the dev's could put this file here for download? Or is it forbidden by some king of rule or EULA?

Share this post


Link to post
Share on other sites
7 minutes ago, Haeffound said:

I saw this fix on the Steam forum indeed, for the nvidia cards, but I haven't anothe X64 unity game where to get this library...

 

And indeed, it is the same error on my side. Maybe someone or the dev's could put this file here for download? Or is it forbidden by some king of rule or EULA?

 

Indeed, I would assume it's against the EULA. However, you should be able to disable the Steam runtime during games by launching steam (or your game) like so:

[breakingmatter:~]$ STEAM_RUNTIME=0 steam

Try that and see if the game starts. If it does, then you can at least play the game until the devs fix it.

 

Share this post


Link to post
Share on other sites

@breakingmatter  Aaaarrgh!  thankyou - I saw many copies libsteam_api but I also saw another missing lib in Player.log, so I didnt bother trying. At least one of us doesnt give up so easily :P

 

@Haeffound I can confirm breaking's fix works - looking through my file system i notice tabletop simulator has 64bit version too - and I think that is free. Otherwise Rivalry is very cheap and you are suporting an indie dev who is still in high school (or at least he was when I met him at PAX Melbourne) and that has it too.

 

Now if you peeps will excuse me I'm off to play the game :D

Share this post


Link to post
Share on other sites

@okster No problem! I saw a ton of stuff missing when I first looked, but "libsteam_api.so" seemed like one that might be somewhere else so I figured it was a place to start. Luckily I just happened to have Sanctum 2 installed. Then I thought about the STEAM_RUNTIME env var. Glad it's working for you!

 

@Haeffound Hopefully the STEAM_RUNTIME env var works for you

@okster @Haeffound I just found this: https://steamcommunity.com/games/352720/announcements/detail/1692679423636146620

 

If you look at the bottom of the post, in the list of fixes it says "- Added missing Steam DLL for Linux". I guess that's what we need to do! Im going to switch to that branch. Never heard of that before.

Share this post


Link to post
Share on other sites

@breakingmatter

I will try tomorrow this steam_runntime fix, I am not at home until then, thank a lot for tips!

 

@okster good game to you, enjoy! B) As for buy another game, I have so little gaming time... That is already taken by so many stuff! :lol:

Share this post


Link to post
Share on other sites

@Haeffound I updated my last message, re-read it and check the bottom. I think if you switch to the experimental branch the fix for the missing library is there. THat's what it seems like from that post anyways. I just updated and started a new game and it's working for me. So I guess the update does work.

Share this post


Link to post
Share on other sites

Great that the dev's put the file and correct some other bugs, I will pass on this branch tomorrow so.

Maybe @okster can put a [resolved] in the subject of the thread.

 

Linux gaming will not fail, thanks guys.

Share this post


Link to post
Share on other sites

Hey thanks @okster for setting up a thread for this issue. I found a copy of the libraries on my copy of Prison Architect. Cheers.

Share this post


Link to post
Share on other sites

×