Jump to content
LadyDreamWriter

Slow movement and flickering screen

Recommended Posts

All right, I FINALLY got the game to load, but the movement seems really slow and glitchy. I'm also having an issue with my screen either freezing for a few minutes showing the Windows Error message: 'this program is not responding'. The screen will also flicker between the game and the desktop repeatedly.

 

Anyone else having this issue? How do I fix this?  

Share this post


Link to post
Share on other sites

This one makes me a little more stumped. @Plazmadawg do you have any ideas? 

Have you checked to see what your CPU usage and stuff like that?

Share this post


Link to post
Share on other sites

I have plenty of room on my hard drive, and I can run Sims 3 and all my other online RP games (SWOR and Fiesta Online) without a problem- already ran a virus scan and that came back clean.

Share this post


Link to post
Share on other sites

Are you using a graphics card in your computer, flickering screens can usually point to a driver issue.

 

When last did you update your graphics card driver? I believe there maybe more to this but lets start off with the simpler issues first.

 

Share this post


Link to post
Share on other sites

I don't know, I would assume so, but again, I have no idea when it was last updated. I don't even know what kind it is.

Share this post


Link to post
Share on other sites

okay the easiest way to determine what graphics card you have do the following:

 

1) In the search bar type "device manager"

 

Untitled.jpg.59cdd4a7ab8a3acb59e6fb43f9ca2426.jpg

 

2) in the device manager click on Display Adapters, what do you have under your display adapters?

 

Untitled.jpg.592a095271b2b212aaae0957134aefe2.jpg

Share this post


Link to post
Share on other sites

I have a ATI Radeon HD 4250

Share this post


Link to post
Share on other sites

Okay follow the below link and click on download under the "Automatically Detect and Install Your Driver".

 

http://support.amd.com/en-us/download

 

Let it install the drivers and you may need to restart your machine, once that is try to start the game again.

Share this post


Link to post
Share on other sites

okay, did that and had to restart the computer- now what?

Share this post


Link to post
Share on other sites

sorry for the late response have you tried to launch the game again to see if allows you to play the game?

Share this post


Link to post
Share on other sites

no, not yet, wanted to make sure there was nothing else I needed to do with the program

Share this post


Link to post
Share on other sites

Update: Nope, no change, still jerky

Share this post


Link to post
Share on other sites

hmm, let me look into it further. I will get back, I want to try a few things

Share this post


Link to post
Share on other sites

okay, thank you so much for your help. If it helps any, my Steam launcher is acting up too- along with the game 'Empires of the undergrowth' (same slowness).

Share this post


Link to post
Share on other sites

Hmm that's interesting. When you open the game, open task manager as well and check out the performance. I've seen other people on the forum complaining of that happening.

 

Share this post


Link to post
Share on other sites

Which game? And where do you find the task manager? LOL

Share this post


Link to post
Share on other sites

Run Universim

Hit Control Alt Delete, in that order, holding them down. 

This will open a menu, click task manager. It might be tiny square that lists what you have open and running on your PC. If that is the case, hit More Details. It should be towards the bottom, at least on mine it is. 

This will open a more intensive menu. Click the tab on the tab that says Performance and you can find the info there.

 

 

Share this post


Link to post
Share on other sites

Weird, I've done the 'three-finger salute' before and it's never done anything like that. BTW how do you exit the game from the planet screen?

Share this post


Link to post
Share on other sites

I've never heard of that term haha. Either Ctrl Alt Tab, cycle to the desktop and then close it. Or while in game you can hit Esc and quit from there. Or you can close it from task manager

Share this post


Link to post
Share on other sites

interesting, good to know

interesting, good to know

 

Okay, I brought it up and hit the performance tab- what should I be looking for? The numbers jump all over the place

Share this post


Link to post
Share on other sites

Any of them stay particularly high? CPU is the first I always check. Then RAM and Graphics ~ but I doubt your graphics would be part of it. 

@Plazmadawg probably knows more about this

 

Share this post


Link to post
Share on other sites

CPU fluxs anywhere from 48% to 70% Ram is good too as far as I can tell

Share this post


Link to post
Share on other sites
7 hours ago, LadyDreamWriter said:

CPU fluxs anywhere from 48% to 70% Ram is good too as far as I can tell

 

The game shouldn't be this laggy even with this sort of usage.

 

7 hours ago, Booty_Queen said:

Any of them stay particularly high? CPU is the first I always check. Then RAM and Graphics ~ but I doubt your graphics would be part of it. 

@Plazmadawg probably knows more about this

 

 

Games can act really weird when your drivers are out of date, games tend to crash as well if your drivers are not up to date. 

 

@LadyDreamWriter

 

it must be the PC itself. Only problem is trying to troubleshoot a computer with out physically being there or on it can be a bit tricky. I would suggest a complete reinstall of the game however I doubt it will bare any fruit. 

 

Upon further research, I have followed up on the card you are running (ATI Radeon HD 4250). Your specs are as follows:

 

Memory type : DDR2

Memory bus: 64 bit
Memory: 512 MB

 

I think your system itself is the culprit over here, judging by the card you currently have installed, your system may be pretty old thus I think it is battling to manage. The same way I asked you to look up the graphics card you are using, could you possibly do the same thing again however this time tell me the model of your processor is?

 

EDIT: I am struggling to find the official system requirements for this title. Does anyone know?  

Share this post


Link to post
Share on other sites

This is what it says when I look up the processor:

 

AMD Athlon(tm) II X4 620 processor

Driver provider: Microsoft
Driver Date: 6/21/2006
Driver version: 6.1.7600.16385
Digital signer: Microsoft Windows

 

Driver is up to date- already checked

 

I looked for them too and couldn't find them- if I had I would have never bought the game knowing that the computer was having this much trouble.

Share this post


Link to post
Share on other sites

Yeah the more I look into it, I think the age of your hardware is battling to keep up with the more intensive games coming out.

 

I hate to say it but you may need to look into upgrading your computers hardware as your processor only has a 2MB Cache, which is really low. You don't have to go too expensive but upgrading it a tad will make a world of a difference.

Share this post


Link to post
Share on other sites

×