Jump to content

Search the Community

Showing results for tags 'wont launch'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Games
    • The Universim
    • Goblins of Elderstone
    • Cefore
    • Prehistoric Kingdom
    • Other Games
  • Crytivo Store
    • News and Announcements
    • Store Discussion
    • Contest, Incentives and Giveaways
  • Community Discussion
    • Forums Rules and Important Information
    • International Communities
    • Off-Topic Discussion

Found 1 result

  1. Steam Version Won't Launch

    I just got the game via Steam, and it won't launch. For maybe 1 second max, the Steam "Preparing to The Universim" pops up, disappears and then nothing. The game looks like it downloaded correctly to my Steam library, on a separate drive to where Windows is installed - the game folder is showing as 1.35GB, although the download window stated it was only 525MB???? PC Specs: Windows 10 64bit (version 1803) Intel i7 4790k GTX 970 32GB RAM I know it's only in early access, so this is a gripe/request for help, and not a complaint! Looking forward to getting this up and running after seeing some good YouTube videos on this. Edit: My under-powered laptop has just downloaded the game. This has the game running from the default Steam C: drive location and works fine, apart from the fact that it only has a 740M graphics chip and an old hat core i5 - but it is Win10 v1803. I have tried moving the install folder on the problem PC back to the default Steam location, but it still seems to have the same issue as stated in the original post. Thanks.
×